處理器 AMD 安全記憶體加密 SME 功能有缺陷, Linux 內核改為預設關閉

soothepain

full loading
已加入
9/17/03
訊息
18,203
互動分數
1,805
點數
113
網站
www.coolaler.com
AMD 的安全記憶體加密(SME)功能被發現存在缺陷,可能會對某些 Linux 系統造成問題。這是在前幾天,被 Linux 工程師 Paul Menzel 發現的,安全記憶體加密功能導致某些配備代號 Raven Ridge 的 APU 啟動失敗。

Ryzen_PRO_5000.jpg


據來源消息稱,Linux 5.15 內核正在使用一個新的修復程式,其中包括禁用 AMD 的安全記憶體加密功能。該功能預設情況下是開通的,但是被發現在某系列 AMD 系統上出現啟動失敗後,現在改為預設關閉。開發人員將首先更新 Linux 5.15 內核,但這個更改也將轉移到之前的內核上。

AMD的安全記憶體加密是一項提供給 EPYC 和 Ryzen Pro 系列處理器的功能,允許處理器在硬體等級對記憶體進行加密。 AMD 表示,這項功能對效能上沒有顯著的影響,並且適用於任何操作系統和應用程式,因為是硬體加速,所以不會依賴於軟體。

儘管看起來有不少的好處,但安全記憶體加密功能在 Linux 驅動中出現了與 IOMMU 和圖形驅動交互的錯誤,導致 Linux 系統主機啟動失敗。受影響的系統也不能識別加密的記憶體,特別是因為某些設備沒有正確的直接存取記憶體 API 或韌體來支援 SMU。這個錯誤主要發生在代號 Raven Ridge 的 APU 上,其他 Ryzen 系列處理器也有可能會遇到。目前通過暫時禁用的方式解決,直到合適的解決方案出現為止。當然,這個問題不會影響 Windows 系統的用戶。





來源
 
▌延伸閱讀